Bolt Unrestricted Upload of File with Dangerous Type
CVE-2019-9185GHSA-gmg5-f2gm-p3h7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bolt/bolt 3.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist bolt/bolt
- Affected
- < 3.6.5
- Fixed in
- 3.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gmg5-f2gm-p3h7 lists affected ranges: Packagist bolt/bolt >=0 <3.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-9185: 2.66% estimated exploitation activity in the next 30 days; percentile 85.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Controller/Async/FilesystemManager.php in the filemanager in Bolt before 3.6.5 allows remote attackers to execute arbitrary PHP code by renaming a previously uploaded file to have a .php extension.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gmg5-f2gm-p3h7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-9185 Advisory: Bolt Unrestricted Upload of File with Dangerous Type IDs: CVE-2019-9185, GHSA-gmg5-f2gm-p3h7 Record: https://patchnext.com/advisories/cve-2019-9185 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bolt/bolt 3.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist bolt/bolt: affected < 3.6.5; fixed in 3.6.5 ## Suggested inspection (read-only) - Packagist bolt/bolt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bolt/bolt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gmg5-f2gm-p3h7 (GitHub-reviewed advisory GHSA-gmg5-f2gm-p3h7 lists affected ranges: Packagist bolt/bolt >=0 <3.6.5) Commands are suggestions: review each one before running it.
Loading voting…