RubyGems Escape sequence injection vulnerability in verbose
CVE-2019-8321GHSA-fr32-gr5c-xq5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rubygems-update 3.0.2, 2.7.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rubygems-update
- Affected
- >= 2.6.0, < 2.7.9>= 3.0.0, < 3.0.2
- Fixed in
- 3.0.2, 2.7.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fr32-gr5c-xq5c lists affected ranges: RubyGems rubygems-update >=2.6.0 =3.0.0 <3.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2019-8321: 3.28% estimated exploitation activity in the next 30 days; percentile 88.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fr32-gr5c-xq5c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-8321 Advisory: RubyGems Escape sequence injection vulnerability in verbose IDs: CVE-2019-8321, GHSA-fr32-gr5c-xq5c Record: https://patchnext.com/advisories/cve-2019-8321 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rubygems-update 3.0.2, 2.7.9. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rubygems-update: affected >= 2.6.0, < 2.7.9; >= 3.0.0, < 3.0.2; fixed in 3.0.2, 2.7.9 ## Suggested inspection (read-only) - RubyGems rubygems-update: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rubygems-update. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fr32-gr5c-xq5c (GitHub-reviewed advisory GHSA-fr32-gr5c-xq5c lists affected ranges: RubyGems rubygems-update >=2.6.0 =3.0.0 <3.0.2) Commands are suggestions: review each one before running it.
Loading voting…