Magento Broken authentication and session managememt
CVE-2019-8108GHSA-92ph-xm9v-cg3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (magento/community-edition 2.3.2-p2, 2.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/community-edition
- Affected
- >= 2.2, < 2.2.10>= 2.3, < 2.3.2-p2
- Fixed in
- 2.3.2-p2, 2.2.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-92ph-xm9v-cg3j lists affected ranges: Packagist magento/community-edition >=2.2 =2.3 <2.3.2-p2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2019-8108: 1.17% estimated exploitation activity in the next 30 days; percentile 67.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can manipulate session validation setting for a storefront that leads to insecure authentication and session management.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-92ph-xm9v-cg3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-8108 Advisory: Magento Broken authentication and session managememt IDs: CVE-2019-8108, GHSA-92ph-xm9v-cg3j Record: https://patchnext.com/advisories/cve-2019-8108 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: magento/community-edition 2.3.2-p2, 2.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/community-edition: affected >= 2.2, < 2.2.10; >= 2.3, < 2.3.2-p2; fixed in 2.3.2-p2, 2.2.10 ## Suggested inspection (read-only) - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-92ph-xm9v-cg3j (GitHub-reviewed advisory GHSA-92ph-xm9v-cg3j lists affected ranges: Packagist magento/community-edition >=2.2 =2.3 <2.3.2-p2) Commands are suggestions: review each one before running it.
Loading voting…