Skip to content

← Actionable
Medium, CVSS 5.3

Magento 2 Community Edition Information Disclosure

CVE-2019-7898GHSA-vqxq-3wqv-r9xp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (magento/community-edition 2.3.2, 2.2.9, 2.1.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-7898: 0.93% estimated exploitation activity in the next 30 days; percentile 60.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Samples of disabled downloadable products are accessible in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 due to inadequate validation of user input.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vqxq-3wqv-r9xp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-7898

Advisory: Magento 2 Community Edition Information Disclosure
IDs: CVE-2019-7898, GHSA-vqxq-3wqv-r9xp
Record: https://patchnext.com/advisories/cve-2019-7898 (revision 1, source checked 26 Oct 2026, 14:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: magento/community-edition 2.3.2, 2.2.9, 2.1.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist magento/community-edition: affected >= 2.1, < 2.1.18; >= 2.2, < 2.2.9; >= 2.3, < 2.3.2; fixed in 2.1.18, 2.2.9, 2.3.2

## Suggested inspection (read-only)
- Packagist magento/community-edition: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vqxq-3wqv-r9xp (GitHub-reviewed advisory GHSA-vqxq-3wqv-r9xp lists affected ranges: Packagist magento/community-edition >=2.1 =2.2 =2.3 <2.3.2)

Commands are suggestions: review each one before running it.

Loading voting…