SQL Injection in NukeViet
CVE-2019-7726GHSA-q4qv-fmwc-qxpx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nukeviet/nukeviet 4.3.04), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist nukeviet/nukeviet
- Affected
- < 4.3.04
- Fixed in
- 4.3.04
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4qv-fmwc-qxpx lists affected ranges: Packagist nukeviet/nukeviet >=0 <4.3.04
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-7726: 2.31% estimated exploitation activity in the next 30 days; percentile 83.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
modules/banners/funcs/click.php in NukeViet before 4.3.04 has a SQL INSERT statement with raw header data from an HTTP request (e.g., Referer and User-Agent).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q4qv-fmwc-qxpx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-7726 Advisory: SQL Injection in NukeViet IDs: CVE-2019-7726, GHSA-q4qv-fmwc-qxpx Record: https://patchnext.com/advisories/cve-2019-7726 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nukeviet/nukeviet 4.3.04. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist nukeviet/nukeviet: affected < 4.3.04; fixed in 4.3.04 ## Suggested inspection (read-only) - Packagist nukeviet/nukeviet: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nukeviet/nukeviet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q4qv-fmwc-qxpx (GitHub-reviewed advisory GHSA-q4qv-fmwc-qxpx lists affected ranges: Packagist nukeviet/nukeviet >=0 <4.3.04) Commands are suggestions: review each one before running it.
Loading voting…