Elastic APM agent for Python client CGI proxy redirection flaw
CVE-2019-7617GHSA-22jh-6gx8-f944
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (elastic-apm 5.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI elastic-apm
- Affected
- < 5.1.0
- Fixed in
- 5.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-22jh-6gx8-f944 lists affected ranges: PyPI elastic-apm >=0 <5.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-22jh-6gx8-f944 lists affected ranges: PyPI elastic-apm >=0 <5.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2019-7617: 1.51% estimated exploitation activity in the next 30 days; percentile 74.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When the Elastic APM agent for Python versions before 5.1.0 is run as a CGI script, there is a variable name clash flaw if a remote attacker can control the proxy header. This could result in an attacker redirecting collected APM data to a proxy of their choosing.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-22jh-6gx8-f944
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-22jh-6gx8-f944
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-7617 Advisory: Elastic APM agent for Python client CGI proxy redirection flaw IDs: CVE-2019-7617, GHSA-22jh-6gx8-f944 Record: https://patchnext.com/advisories/cve-2019-7617 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: elastic-apm 5.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI elastic-apm: affected < 5.1.0; fixed in 5.1.0 ## Suggested inspection (read-only) - `python -m pip show elastic-apm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on elastic-apm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-22jh-6gx8-f944 (OSV record GHSA-22jh-6gx8-f944 lists affected ranges: PyPI elastic-apm >=0 <5.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-22jh-6gx8-f944 (GitHub-reviewed advisory GHSA-22jh-6gx8-f944 lists affected ranges: PyPI elastic-apm >=0 <5.1.0) Commands are suggestions: review each one before running it.
Loading voting…