Concurrent Execution using Shared Resource with Improper Synchronization in Elasticsearch
CVE-2019-7614GHSA-jqm6-m3j3-8gg9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.elasticsearch:elasticsearch 7.2.1, 6.8.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.elasticsearch:elasticsearch
- Affected
- < 6.8.2>= 7.0.0, < 7.2.1
- Fixed in
- 6.8.2, 7.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqm6-m3j3-8gg9 lists affected ranges: Maven org.elasticsearch:elasticsearch >=0 =7.0.0 <7.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2019-7614: 1.01% estimated exploitation activity in the next 30 days; percentile 63.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A race condition flaw was found in the response headers Elasticsearch versions before 7.2.1 and 6.8.2 returns to a request. On a system with multiple users submitting requests, it could be possible for an attacker to gain access to response header containing sensitive data from another user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jqm6-m3j3-8gg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-7614 Advisory: Concurrent Execution using Shared Resource with Improper Synchronization in Elasticsearch IDs: CVE-2019-7614, GHSA-jqm6-m3j3-8gg9 Record: https://patchnext.com/advisories/cve-2019-7614 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.elasticsearch:elasticsearch 7.2.1, 6.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.elasticsearch:elasticsearch: affected < 6.8.2; >= 7.0.0, < 7.2.1; fixed in 6.8.2, 7.2.1 ## Suggested inspection (read-only) - Maven org.elasticsearch:elasticsearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.elasticsearch:elasticsearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jqm6-m3j3-8gg9 (GitHub-reviewed advisory GHSA-jqm6-m3j3-8gg9 lists affected ranges: Maven org.elasticsearch:elasticsearch >=0 =7.0.0 <7.2.1) Commands are suggestions: review each one before running it.
Loading voting…