Croogo vulnerable to XSS in title field
CVE-2019-7170GHSA-36pq-cjh9-fv46
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (croogo/croogo 3.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist croogo/croogo
- Affected
- < 3.0.7
- Fixed in
- 3.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-36pq-cjh9-fv46 lists affected ranges: Packagist croogo/croogo >=0 <3.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-7170: 0.61% estimated exploitation activity in the next 30 days; percentile 49.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A stored-self XSS exists in Croogo allowing an attacker to execute HTML or JavaScript code in a vulnerable Title field to /admin/taxonomy/vocabularies.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-36pq-cjh9-fv46
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-7170 Advisory: Croogo vulnerable to XSS in title field IDs: CVE-2019-7170, GHSA-36pq-cjh9-fv46 Record: https://patchnext.com/advisories/cve-2019-7170 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: croogo/croogo 3.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist croogo/croogo: affected < 3.0.7; fixed in 3.0.7 ## Suggested inspection (read-only) - Packagist croogo/croogo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on croogo/croogo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-36pq-cjh9-fv46 (GitHub-reviewed advisory GHSA-36pq-cjh9-fv46 lists affected ranges: Packagist croogo/croogo >=0 <3.0.7) Commands are suggestions: review each one before running it.
Loading voting…