Skip to content

← Actionable
Medium, CVSS 5.4

Drupal Cross Site Scripting (XSS) vulnerability

CVE-2019-6341GHSA-cmmh-8mwp-gq5p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.6.13, 8.5.14, 7.65.0; drupal/drupal 8.6.13, 8.5.14, 7.65.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0.0, < 7.65.0>= 8.0.0, < 8.5.14>= 8.6.0, < 8.6.13
    Fixed in
    8.5.14, 8.6.13, 7.65.0
  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.65.0>= 8.0.0, < 8.5.14>= 8.6.0, < 8.6.13
    Fixed in
    8.5.14, 8.6.13, 7.65.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-6341: 12.19% estimated exploitation activity in the next 30 days; percentile 96.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cmmh-8mwp-gq5p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-6341

Advisory: Drupal Cross Site Scripting (XSS) vulnerability
IDs: CVE-2019-6341, GHSA-cmmh-8mwp-gq5p
Record: https://patchnext.com/advisories/cve-2019-6341 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.6.13, 8.5.14, 7.65.0; drupal/drupal 8.6.13, 8.5.14, 7.65.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0.0, < 7.65.0; >= 8.0.0, < 8.5.14; >= 8.6.0, < 8.6.13; fixed in 8.5.14, 8.6.13, 7.65.0
- Packagist drupal/drupal: affected >= 7.0.0, < 7.65.0; >= 8.0.0, < 8.5.14; >= 8.6.0, < 8.6.13; fixed in 8.5.14, 8.6.13, 7.65.0

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cmmh-8mwp-gq5p (GitHub-reviewed advisory GHSA-cmmh-8mwp-gq5p lists affected ranges: Packagist drupal/core >=7.0.0 =8.0.0 =8.6.0 =7.0.0 =8.0.0 =8.6.0 <8.6.13)

Commands are suggestions: review each one before running it.

Loading voting…