Skip to content

← Actionable
High, CVSS 8.1Exploited · CISA KEV

Drupal Core Remote Code Execution Vulnerability

CVE-2019-6340GHSA-3gx6-h57h-rm27

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.6.10, 8.5.11, 7.62.0; drupal/drupal 8.6.10, 8.5.11, 7.62.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.6.0, < 8.6.10>= 7.0.0, < 7.62.0>= 8.0.0, < 8.5.11
    Fixed in
    8.5.11, 7.62.0, 8.6.10
  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.62.0>= 8.0.0, < 8.5.11>= 8.6.0, < 8.6.10
    Fixed in
    8.5.11, 7.62.0, 8.6.10

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2019-6340: 92.02% estimated exploitation activity in the next 30 days; percentile 99.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3gx6-h57h-rm27

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-6340

Advisory: Drupal Core Remote Code Execution Vulnerability
IDs: CVE-2019-6340, GHSA-3gx6-h57h-rm27
Record: https://patchnext.com/advisories/cve-2019-6340 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.6.10, 8.5.11, 7.62.0; drupal/drupal 8.6.10, 8.5.11, 7.62.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.6.0, < 8.6.10; >= 7.0.0, < 7.62.0; >= 8.0.0, < 8.5.11; fixed in 8.5.11, 7.62.0, 8.6.10
- Packagist drupal/drupal: affected >= 7.0.0, < 7.62.0; >= 8.0.0, < 8.5.11; >= 8.6.0, < 8.6.10; fixed in 8.5.11, 7.62.0, 8.6.10

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3gx6-h57h-rm27 (GitHub-reviewed advisory GHSA-3gx6-h57h-rm27 lists affected ranges: Packagist drupal/core >=8.6.0 =7.0.0 =8.0.0 =7.0.0 =8.0.0 =8.6.0 <8.6.10)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-6340 to the Known Exploited Vulnerabilities catalog on 2022-03-25.)

Commands are suggestions: review each one before running it.

Loading voting…