Skip to content

← Actionable
High, CVSS 8.0

Drupal core third-party PEAR Archive_Tar library is vulnerable to Deserialization of Untrusted Data

CVE-2019-6338GHSA-6rmq-x2hv-vxpp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/drupal 8.6.6, 8.5.9, 7.62.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/drupal

    Affected
    >= 7.0.0, < 7.62.0>= 8.0.0, < 8.5.9>= 8.6.0, < 8.6.6
    Fixed in
    8.5.9, 8.6.6, 7.62.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-6338: 2.12% estimated exploitation activity in the next 30 days; percentile 81.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR ArchiveTar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6rmq-x2hv-vxpp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-6338

Advisory: Drupal core third-party PEAR Archive_Tar library is vulnerable to Deserialization of Untrusted Data
IDs: CVE-2019-6338, GHSA-6rmq-x2hv-vxpp
Record: https://patchnext.com/advisories/cve-2019-6338 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/drupal 8.6.6, 8.5.9, 7.62.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/drupal: affected >= 7.0.0, < 7.62.0; >= 8.0.0, < 8.5.9; >= 8.6.0, < 8.6.6; fixed in 8.5.9, 8.6.6, 7.62.0

## Suggested inspection (read-only)
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6rmq-x2hv-vxpp (GitHub-reviewed advisory GHSA-6rmq-x2hv-vxpp lists affected ranges: Packagist drupal/drupal >=7.0.0 =8.0.0 =8.6.0 <8.6.6)

Commands are suggestions: review each one before running it.

Loading voting…