Sensitive Data Exposure in elFinder
CVE-2019-5884GHSA-jcgc-vxqg-85xx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (studio-42/elfinder 2.1.45), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist studio-42/elfinder
- Affected
- < 2.1.45
- Fixed in
- 2.1.45
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jcgc-vxqg-85xx lists affected ranges: Packagist studio-42/elfinder >=0 <2.1.45
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2019-5884: 1.27% estimated exploitation activity in the next 30 days; percentile 69.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
php/elFinder.class.php in elFinder before 2.1.45 leaks information if PHP's curl extension is enabled and safemode or openbasedir is not set.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jcgc-vxqg-85xx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-5884 Advisory: Sensitive Data Exposure in elFinder IDs: CVE-2019-5884, GHSA-jcgc-vxqg-85xx Record: https://patchnext.com/advisories/cve-2019-5884 (revision 1, source checked 26 Oct 2026, 14:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: studio-42/elfinder 2.1.45. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist studio-42/elfinder: affected < 2.1.45; fixed in 2.1.45 ## Suggested inspection (read-only) - Packagist studio-42/elfinder: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on studio-42/elfinder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jcgc-vxqg-85xx (GitHub-reviewed advisory GHSA-jcgc-vxqg-85xx lists affected ranges: Packagist studio-42/elfinder >=0 <2.1.45) Commands are suggestions: review each one before running it.
Loading voting…