Use-After-Free in puppeteer
CVE-2019-5786GHSA-c2gp-86p4-5935
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (puppeteer 1.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm puppeteer
- Affected
- < 1.13.0
- Fixed in
- 1.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c2gp-86p4-5935 lists affected ranges: npm puppeteer >=0 <1.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2019-5786 to the Known Exploited Vulnerabilities catalog on 2022-05-23.
VerifiedObserved Listed in the CISA KEV JSON feed; separate from customer applicability.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c2gp-86p4-5935 lists affected ranges: npm puppeteer >=0 <1.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2019-5786 to the Known Exploited Vulnerabilities catalog on 2022-05-23.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-05-23).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2019-5786: 61.09% estimated exploitation activity in the next 30 days; percentile 99.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of puppeteer prior to 1.13.0 are vulnerable to the Use-After-Free vulnerability in Chromium (CVE-2019-5786). The Chromium FileReader API is vulnerable to Use-After-Free which may lead to Remote Code Execution. Recommendation Upgrade to version 1.13.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c2gp-86p4-5935
- Revision 2 · evidence added ·
CISA KEV confirmed exploitation for CVE-2019-5786 (date added 2022-05-23). Customer workflow unchanged.
- Revision 1 · created ·
Published from osv record GHSA-c2gp-86p4-5935
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-5786 Advisory: Use-After-Free in puppeteer IDs: CVE-2019-5786, GHSA-c2gp-86p4-5935 Record: https://patchnext.com/advisories/cve-2019-5786 (revision 3, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: puppeteer 1.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm puppeteer: affected < 1.13.0; fixed in 1.13.0 ## Suggested inspection (read-only) - `npm ls puppeteer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on puppeteer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c2gp-86p4-5935 (OSV record GHSA-c2gp-86p4-5935 lists affected ranges: npm puppeteer >=0 <1.13.0 (fixed)) - Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2019-5786 to the Known Exploited Vulnerabilities catalog on 2022-05-23.) - Verified: https://github.com/advisories/GHSA-c2gp-86p4-5935 (GitHub-reviewed advisory GHSA-c2gp-86p4-5935 lists affected ranges: npm puppeteer >=0 <1.13.0) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-5786 to the Known Exploited Vulnerabilities catalog on 2022-05-23.) Commands are suggestions: review each one before running it.
Loading voting…