Skip to content

← Actionable
Medium, CVSS 5.3amended

Unauthorized File Access in harp

CVE-2019-5438GHSA-6fmm-47qc-p4m4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (harp 0.40.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm harp

    Affected
    < 0.40.3
    Fixed in
    0.40.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-5438: 1.49% estimated exploitation activity in the next 30 days; percentile 74.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

All versions of harp are vulnerable to Unauthorized File Access. If a symlink in the project's base directory points to a file outside of the directory, the file is served. This could allow an attacker to access sensitive files on the server. Recommendation No fix is currently available. Consider using an alternative module until a fix is made available.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6fmm-47qc-p4m4

  2. Revision 1 · created ·

    Published from osv record GHSA-6fmm-47qc-p4m4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-5438

Advisory: Unauthorized File Access in harp
IDs: CVE-2019-5438, GHSA-6fmm-47qc-p4m4
Record: https://patchnext.com/advisories/cve-2019-5438 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: harp 0.40.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm harp: affected < 0.40.3; fixed in 0.40.3

## Suggested inspection (read-only)
- `npm ls harp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on harp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6fmm-47qc-p4m4 (OSV record GHSA-6fmm-47qc-p4m4 lists affected ranges: npm harp >=0 <0.40.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6fmm-47qc-p4m4 (GitHub-reviewed advisory GHSA-6fmm-47qc-p4m4 lists affected ranges: npm harp >=0 <0.40.3)

Commands are suggestions: review each one before running it.

Loading voting…