Skip to content

← Actionable
High, CVSS 7.5Exploited · CISA KEV

Path Traversal in Action View

CVE-2019-5418GHSA-86g5-2wh3-gc9j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionview 5.2.2.1, 5.1.6.2, 5.0.7.2, 4.2.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionview

    Affected
    >= 5.1.0, <= 5.1.6.1>= 5.0.0, <= 5.0.7.1>= 5.2.0, <= 5.2.2.0>= 4.0.0, <= 4.2.11.0
    Fixed in
    5.1.6.2, 4.2.11.1, 5.2.2.1, 5.0.7.2

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:H
EPSS
  • CVE-2019-5418: 98.51% estimated exploitation activity in the next 30 days; percentile 99.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

File Content Disclosure in Action View Impact ------ There is a possible file content disclosure vulnerability in Action View. Specially crafted accept headers in combination with calls to render file: can cause arbitrary files on the target server to be rendered, disclosing the file contents. The impact is limited to calls to render which render file contents without a specified accept format. Impacted code in a controller looks something like this: Rendering templates as opposed to files is not impacted by this vulnerability. All users running an affected release should either upgrade or use one of the workarounds immediately. Releases -------- The 6.0.0.beta3, 5.2.2.1, 5.1.6.2, 5.0.7.2, and 4.2.11.1 releases are available at the normal locations. Workarounds ----------- This vulnerability can be mitigated by specifying a format for file rendering, like this: In summary, impacted calls to render look like this: The vulnerability can be mitigated by changing to this: Other calls to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-86g5-2wh3-gc9j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-5418

Advisory: Path Traversal in Action View
IDs: CVE-2019-5418, GHSA-86g5-2wh3-gc9j
Record: https://patchnext.com/advisories/cve-2019-5418 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: actionview 5.2.2.1, 5.1.6.2, 5.0.7.2, 4.2.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionview: affected >= 5.1.0, <= 5.1.6.1; >= 5.0.0, <= 5.0.7.1; >= 5.2.0, <= 5.2.2.0; >= 4.0.0, <= 4.2.11.0; fixed in 5.1.6.2, 4.2.11.1, 5.2.2.1, 5.0.7.2

## Suggested inspection (read-only)
- RubyGems actionview: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionview.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-86g5-2wh3-gc9j (GitHub-reviewed advisory GHSA-86g5-2wh3-gc9j lists affected ranges: RubyGems actionview >=5.1.0 =5.0.0 =5.2.0 =4.0.0 <=4.2.11.0)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-5418 to the Known Exploited Vulnerabilities catalog on 2025-07-07.)

Commands are suggestions: review each one before running it.

Loading voting…