Command Injection in kill-port
CVE-2019-5414GHSA-pmv6-gf98-p3r5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kill-port 1.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm kill-port
- Affected
- < 1.3.2
- Fixed in
- 1.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pmv6-gf98-p3r5 lists affected ranges: npm kill-port >=0 <1.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pmv6-gf98-p3r5 lists affected ranges: npm kill-port >=0 <1.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-5414: 1.89% estimated exploitation activity in the next 30 days; percentile 79.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of kill-port prior to 1.3.2 are vulnerable to Command Injection. The package does not validate user input on the kill function. This may allow attackers to run arbitrary commands in the system if user input (such as the port number) is passed directly to the function. Recommendation Upgrade to version 1.3.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pmv6-gf98-p3r5
- Revision 1 · created ·
Published from osv record GHSA-pmv6-gf98-p3r5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-5414 Advisory: Command Injection in kill-port IDs: CVE-2019-5414, GHSA-pmv6-gf98-p3r5 Record: https://patchnext.com/advisories/cve-2019-5414 (revision 2, source checked 26 Oct 2026, 12:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kill-port 1.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm kill-port: affected < 1.3.2; fixed in 1.3.2 ## Suggested inspection (read-only) - `npm ls kill-port --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kill-port. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pmv6-gf98-p3r5 (OSV record GHSA-pmv6-gf98-p3r5 lists affected ranges: npm kill-port >=0 <1.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pmv6-gf98-p3r5 (GitHub-reviewed advisory GHSA-pmv6-gf98-p3r5 lists affected ranges: npm kill-port >=0 <1.3.2) Commands are suggestions: review each one before running it.
Loading voting…