Skip to content

← Actionable
Critical, CVSS 9.8

Credential exposure through log files in Undertow

CVE-2019-3888GHSA-jwgx-9mmh-684w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.undertow:undertow-core 2.0.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-3888: 3.03% estimated exploitation activity in the next 30 days; percentile 87.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in Undertow web server before 2.0.21. An information exposure of plain text credentials through log files because Connectors.executeRootHandler:402 logs the HttpServerExchange object at ERROR level using UndertowLogger.REQUESTLOGGER.undertowRequestFailed(t, exchange)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jwgx-9mmh-684w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-3888

Advisory: Credential exposure through log files in Undertow
IDs: CVE-2019-3888, GHSA-jwgx-9mmh-684w
Record: https://patchnext.com/advisories/cve-2019-3888 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.undertow:undertow-core 2.0.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.undertow:undertow-core: affected < 2.0.21; fixed in 2.0.21

## Suggested inspection (read-only)
- Maven io.undertow:undertow-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.undertow:undertow-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jwgx-9mmh-684w (GitHub-reviewed advisory GHSA-jwgx-9mmh-684w lists affected ranges: Maven io.undertow:undertow-core >=0 <2.0.21)

Commands are suggestions: review each one before running it.

Loading voting…