Skip to content

← Actionable
Medium, CVSS 6.5

spring-security-oauth and spring-security-oauth2 Open Redirect vulnerability

CVE-2019-3778GHSA-77rv-6vfw-x4gc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security.oauth:spring-security-oauth 2.3.5.RELEASE, 2.2.4.RELEASE, 2.1.4.RELEASE, 2.0.17.RELEASE; org.springframework.security.oauth:spring-security-oauth2 2.3.5.RELEASE, 2.2.4.RELEASE, 2.1.4.RELEASE, 2.0.17.RELEASE), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-77rv-6vfw-x4gc lists affected ranges: Maven org.springframework.security.oauth:spring-security-oauth >=0 =2.1.0.RELEASE =2.2.0.RELEASE =2.3.0.RELEASE =0 =2.1.0.RELEASE =2.2.0.RELEASE =2.3.0.RELEASE <2.3.5.RELEASE

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2019-3778: 16.60% estimated exploitation activity in the next 30 days; percentile 97.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring Security OAuth, versions 2.3 prior to 2.3.5, and 2.2 prior to 2.2.4, and 2.1 prior to 2.1.4, and 2.0 prior to 2.0.17, and older unsupported versions could be susceptible to an open redirector attack that can leak an authorization code. A malicious user or attacker can craft a request to the authorization endpoint using the authorization code grant type, and specify a manipulated redirection URI via the "redirecturi" parameter. This can cause the authorization server to redirect the resource owner user-agent to a URI under the control of the attacker with the leaked authorization code. This vulnerability exposes applications that meet all of the following requirements: Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer) and uses the DefaultRedirectResolver in the AuthorizationEndpoint. This vulnerability does not expose applications that: Act in the role of an Authorization Server and uses a different RedirectResolver implementation other than…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-77rv-6vfw-x4gc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-3778

Advisory: spring-security-oauth and spring-security-oauth2 Open Redirect vulnerability
IDs: CVE-2019-3778, GHSA-77rv-6vfw-x4gc
Record: https://patchnext.com/advisories/cve-2019-3778 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security.oauth:spring-security-oauth 2.3.5.RELEASE, 2.2.4.RELEASE, 2.1.4.RELEASE, 2.0.17.RELEASE; org.springframework.security.oauth:spring-security-oauth2 2.3.5.RELEASE, 2.2.4.RELEASE, 2.1.4.RELEASE, 2.0.17.RELEASE. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security.oauth:spring-security-oauth: affected < 2.0.17.RELEASE; >= 2.1.0.RELEASE, < 2.1.4.RELEASE; >= 2.2.0.RELEASE, < 2.2.4.RELEASE; >= 2.3.0.RELEASE, < 2.3.5.RELEASE; fixed in 2.3.5.RELEASE, 2.1.4.RELEASE, 2.2.4.RELEASE, 2.0.17.RELEASE
- Maven org.springframework.security.oauth:spring-security-oauth2: affected < 2.0.17.RELEASE; >= 2.1.0.RELEASE, < 2.1.4.RELEASE; >= 2.2.0.RELEASE, < 2.2.4.RELEASE; >= 2.3.0.RELEASE, < 2.3.5.RELEASE; fixed in 2.3.5.RELEASE, 2.1.4.RELEASE, 2.2.4.RELEASE, 2.0.17.RELEASE

## Suggested inspection (read-only)
- Maven org.springframework.security.oauth:spring-security-oauth: check the installed version with your package manager.
- Maven org.springframework.security.oauth:spring-security-oauth2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security.oauth:spring-security-oauth, org.springframework.security.oauth:spring-security-oauth2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-77rv-6vfw-x4gc (GitHub-reviewed advisory GHSA-77rv-6vfw-x4gc lists affected ranges: Maven org.springframework.security.oauth:spring-security-oauth >=0 =2.1.0.RELEASE =2.2.0.RELEASE =2.3.0.RELEASE =0 =2.1.0.RELEASE =2.2.0.RELEASE =2.3.0.RELEASE <2.3.5.RELEASE)

Commands are suggestions: review each one before running it.

Loading voting…