Improper Restriction of XML External Entity Reference in org.springframework.integration:spring-integration-ws and org.springframework.integration:spring-integration-xml
CVE-2019-3772GHSA-wr5r-m8pc-85j9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.integration:spring-integration-ws 5.1.2, 5.0.11, 4.3.19; org.springframework.integration:spring-integration-xml 5.1.2, 5.0.11, 4.3.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.integration:spring-integration-ws
- Affected
- < 4.3.19>= 5.0.0, < 5.0.11>= 5.1.0, < 5.1.2
- Fixed in
- 4.3.19, 5.0.11, 5.1.2
Maven org.springframework.integration:spring-integration-xml
- Affected
- < 4.3.19>= 5.0.0, < 5.0.11>= 5.1.0, < 5.1.2
- Fixed in
- 4.3.19, 5.0.11, 5.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wr5r-m8pc-85j9 lists affected ranges: Maven org.springframework.integration:spring-integration-xml >=0 =5.0.0 =5.1.0 =0 =5.0.0 =5.1.0 <5.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2019-3772: 3.00% estimated exploitation activity in the next 30 days; percentile 87.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Spring Integration (spring-integration-xml and spring-integration-ws modules), versions 4.3.18, 5.0.10, 5.1.1, and older unsupported versions, were susceptible to XML External Entity Injection (XXE) when receiving XML data from untrusted sources.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wr5r-m8pc-85j9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-3772 Advisory: Improper Restriction of XML External Entity Reference in org.springframework.integration:spring-integration-ws and org.springframework.integration:spring-integration-xml IDs: CVE-2019-3772, GHSA-wr5r-m8pc-85j9 Record: https://patchnext.com/advisories/cve-2019-3772 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.integration:spring-integration-ws 5.1.2, 5.0.11, 4.3.19; org.springframework.integration:spring-integration-xml 5.1.2, 5.0.11, 4.3.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.integration:spring-integration-ws: affected < 4.3.19; >= 5.0.0, < 5.0.11; >= 5.1.0, < 5.1.2; fixed in 4.3.19, 5.0.11, 5.1.2 - Maven org.springframework.integration:spring-integration-xml: affected < 4.3.19; >= 5.0.0, < 5.0.11; >= 5.1.0, < 5.1.2; fixed in 4.3.19, 5.0.11, 5.1.2 ## Suggested inspection (read-only) - Maven org.springframework.integration:spring-integration-ws: check the installed version with your package manager. - Maven org.springframework.integration:spring-integration-xml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.integration:spring-integration-ws, org.springframework.integration:spring-integration-xml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wr5r-m8pc-85j9 (GitHub-reviewed advisory GHSA-wr5r-m8pc-85j9 lists affected ranges: Maven org.springframework.integration:spring-integration-xml >=0 =5.0.0 =5.1.0 =0 =5.0.0 =5.1.0 <5.1.2) Commands are suggestions: review each one before running it.
Loading voting…