Renovate vulnerable to leakage of temporary repository tokens into Pull Request comments
CVE-2019-25766GHSA-v7x3-7hw7-pcjg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (renovate 19.38.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm renovate
- Affected
- >= 13.87.0, < 19.38.7
- Fixed in
- 19.38.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v7x3-7hw7-pcjg lists affected ranges: npm renovate >=13.87.0 <19.38.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v7x3-7hw7-pcjg lists affected ranges: npm renovate >=13.87.0 <19.38.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2019-25766: 0.43% estimated exploitation activity in the next 30 days; percentile 37.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Temporary repository tokens were leaked into Pull Requests comments in during certain Go Modules update failure scenarios. Patches The problem has been patched. Self-hosted users should upgrade to v19.38.7 or later. Workarounds Disable Go Modules support. References Blog post: https://renovatebot.com/blog/go-modules-vulnerability-disclosure For more information If you have any questions or comments about this advisory: Open an issue in Renovate
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v7x3-7hw7-pcjg
- Revision 1 · created ·
Published from osv record GHSA-v7x3-7hw7-pcjg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-25766 Advisory: Renovate vulnerable to leakage of temporary repository tokens into Pull Request comments IDs: CVE-2019-25766, GHSA-v7x3-7hw7-pcjg Record: https://patchnext.com/advisories/cve-2019-25766 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: renovate 19.38.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm renovate: affected >= 13.87.0, < 19.38.7; fixed in 19.38.7 ## Suggested inspection (read-only) - `npm ls renovate --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on renovate. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v7x3-7hw7-pcjg (OSV record GHSA-v7x3-7hw7-pcjg lists affected ranges: npm renovate >=13.87.0 <19.38.7 (fixed)) - Verified: https://github.com/advisories/GHSA-v7x3-7hw7-pcjg (GitHub-reviewed advisory GHSA-v7x3-7hw7-pcjg lists affected ranges: npm renovate >=13.87.0 <19.38.7) Commands are suggestions: review each one before running it.
Loading voting…