sanitize-html is vulnerable to XSS through incomprehensive sanitization
CVE-2019-25225GHSA-qhxp-v273-g94h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanitize-html 2.0.0-beta), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sanitize-html
- Affected
- < 2.0.0-beta
- Fixed in
- 2.0.0-beta
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qhxp-v273-g94h lists affected ranges: npm sanitize-html >=0 <2.0.0-beta (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qhxp-v273-g94h lists affected ranges: npm sanitize-html >=0 <2.0.0-beta
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-25225: 0.27% estimated exploitation activity in the next 30 days; percentile 19.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
sanitize-html prior to version 2.0.0-beta is vulnerable to Cross-site Scripting (XSS). The sanitizeHtml() function in index.js does not sanitize content when using the custom transformTags option, which is intended to convert attribute values into text. As a result, malicious input can be transformed into executable code.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qhxp-v273-g94h
- Revision 1 · created ·
Published from osv record GHSA-qhxp-v273-g94h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-25225 Advisory: sanitize-html is vulnerable to XSS through incomprehensive sanitization IDs: CVE-2019-25225, GHSA-qhxp-v273-g94h Record: https://patchnext.com/advisories/cve-2019-25225 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sanitize-html 2.0.0-beta. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sanitize-html: affected < 2.0.0-beta; fixed in 2.0.0-beta ## Suggested inspection (read-only) - `npm ls sanitize-html --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sanitize-html. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qhxp-v273-g94h (OSV record GHSA-qhxp-v273-g94h lists affected ranges: npm sanitize-html >=0 <2.0.0-beta (fixed)) - Verified: https://github.com/advisories/GHSA-qhxp-v273-g94h (GitHub-reviewed advisory GHSA-qhxp-v273-g94h lists affected ranges: npm sanitize-html >=0 <2.0.0-beta) Commands are suggestions: review each one before running it.
Loading voting…