Pedroetb TTS-API OS Command Injection
CVE-2019-25158GHSA-jx6q-fq9h-6g7q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tts-api 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm tts-api
- Affected
- < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jx6q-fq9h-6g7q lists affected ranges: npm tts-api >=0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jx6q-fq9h-6g7q lists affected ranges: npm tts-api >=0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-25158: 2.11% estimated exploitation activity in the next 30 days; percentile 81.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jx6q-fq9h-6g7q
- Revision 1 · created ·
Published from osv record GHSA-jx6q-fq9h-6g7q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-25158 Advisory: Pedroetb TTS-API OS Command Injection IDs: CVE-2019-25158, GHSA-jx6q-fq9h-6g7q Record: https://patchnext.com/advisories/cve-2019-25158 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tts-api 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm tts-api: affected < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - `npm ls tts-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tts-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jx6q-fq9h-6g7q (OSV record GHSA-jx6q-fq9h-6g7q lists affected ranges: npm tts-api >=0 <2.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jx6q-fq9h-6g7q (GitHub-reviewed advisory GHSA-jx6q-fq9h-6g7q lists affected ranges: npm tts-api >=0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…