Skip to content

← Actionable
Medium, CVSS 5.3amended

nsupdate.info has Sensitive Cookie Without 'HttpOnly' Flag

CVE-2019-25091GHSA-mwvp-qr62-cvjx

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nsupdate

    Affected
    <= 0.12.0
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2019-25091: 0.67% estimated exploitation activity in the next 30 days; percentile 52.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability classified as problematic has been found in nsupdate.info. This affects an unknown part of the file src/nsupdate/settings/base.py of the component CSRF Cookie Handler. The manipulation of the argument CSRFCOOKIEHTTPONLY leads to cookie without httponly flag. It is possible to initiate the attack remotely. The name of the patch is 60a3fe559c453bc36b0ec3e5dd39c1303640a59a. It is recommended to apply a patch to fix this issue. The identifier VDB-216909 was assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mwvp-qr62-cvjx

  2. Revision 1 · created ·

    Published from osv record GHSA-mwvp-qr62-cvjx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-25091

Advisory: nsupdate.info has Sensitive Cookie Without 'HttpOnly' Flag
IDs: CVE-2019-25091, GHSA-mwvp-qr62-cvjx
Record: https://patchnext.com/advisories/cve-2019-25091 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nsupdate: affected <= 0.12.0

## Suggested inspection (read-only)
- `python -m pip show nsupdate`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nsupdate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mwvp-qr62-cvjx (OSV record GHSA-mwvp-qr62-cvjx lists affected ranges: PyPI nsupdate >=0 <=0.12.0)
- Verified: https://github.com/advisories/GHSA-mwvp-qr62-cvjx (GitHub-reviewed advisory GHSA-mwvp-qr62-cvjx lists affected ranges: PyPI nsupdate >=0 <=0.12.0)

Commands are suggestions: review each one before running it.

Loading voting…