Improper Access Control in wp-graphql
CVE-2019-25060GHSA-w3xg-7q6m-3xwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wp-graphql/wp-graphql 0.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wp-graphql/wp-graphql
- Affected
- < 0.3.5
- Fixed in
- 0.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w3xg-7q6m-3xwp lists affected ranges: Packagist wp-graphql/wp-graphql >=0 <0.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2019-25060: 1.83% estimated exploitation activity in the next 30 days; percentile 78.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w3xg-7q6m-3xwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-25060 Advisory: Improper Access Control in wp-graphql IDs: CVE-2019-25060, GHSA-w3xg-7q6m-3xwp Record: https://patchnext.com/advisories/cve-2019-25060 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wp-graphql/wp-graphql 0.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wp-graphql/wp-graphql: affected < 0.3.5; fixed in 0.3.5 ## Suggested inspection (read-only) - Packagist wp-graphql/wp-graphql: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wp-graphql/wp-graphql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w3xg-7q6m-3xwp (GitHub-reviewed advisory GHSA-w3xg-7q6m-3xwp lists affected ranges: Packagist wp-graphql/wp-graphql >=0 <0.3.5) Commands are suggestions: review each one before running it.
Loading voting…