PYSEC-2021-888
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gdal 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gdal
- Affected
- >= 2.4.2, < 3.1.0
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2021-888 lists affected ranges: PyPI gdal >=2.4.2 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-25050: 0.35% estimated exploitation activity in the next 30 days; percentile 28.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
netCDF in GDAL 2.4.2 through 3.0.4 has a stack-based buffer overflow in nc4_get_att (called from nc4_get_att_tc and nc_get_att_text) and in uffd_cleanup (called from netCDFDataset::~netCDFDataset and netCDFDataset::~netCDFDataset).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record PYSEC-2021-888
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-25050 Advisory: PYSEC-2021-888 IDs: CVE-2019-25050 Record: https://patchnext.com/advisories/cve-2019-25050 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gdal 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gdal: affected >= 2.4.2, < 3.1.0; fixed in 3.1.0 ## Suggested inspection (read-only) - `python -m pip show gdal`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gdal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2021-888 (OSV record PYSEC-2021-888 lists affected ranges: PyPI gdal >=2.4.2 <3.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…