Stored cross-site scripting in Grid component in Vaadin 7 and 8
CVE-2019-25028GHSA-q74r-4xw3-ppx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:vaadin-bom 8.8.5, 7.7.20; com.vaadin:vaadin-server 8.8.5, 7.7.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.vaadin:vaadin-bom
- Affected
- >= 7.4.0, < 7.7.20>= 8.0.0, < 8.8.5
- Fixed in
- 7.7.20, 8.8.5
Maven com.vaadin:vaadin-server
- Affected
- >= 7.4.0, < 7.7.20>= 8.0.0, < 8.8.5
- Fixed in
- 7.7.20, 8.8.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q74r-4xw3-ppx9 lists affected ranges: Maven com.vaadin:vaadin-bom >=7.4.0 =8.0.0 =7.4.0 =8.0.0 <8.8.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-25028: 0.92% estimated exploitation activity in the next 30 days; percentile 60.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector. - https://vaadin.com/security/cve-2019-25028
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q74r-4xw3-ppx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-25028 Advisory: Stored cross-site scripting in Grid component in Vaadin 7 and 8 IDs: CVE-2019-25028, GHSA-q74r-4xw3-ppx9 Record: https://patchnext.com/advisories/cve-2019-25028 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.vaadin:vaadin-bom 8.8.5, 7.7.20; com.vaadin:vaadin-server 8.8.5, 7.7.20. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.vaadin:vaadin-bom: affected >= 7.4.0, < 7.7.20; >= 8.0.0, < 8.8.5; fixed in 7.7.20, 8.8.5 - Maven com.vaadin:vaadin-server: affected >= 7.4.0, < 7.7.20; >= 8.0.0, < 8.8.5; fixed in 7.7.20, 8.8.5 ## Suggested inspection (read-only) - Maven com.vaadin:vaadin-bom: check the installed version with your package manager. - Maven com.vaadin:vaadin-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.vaadin:vaadin-bom, com.vaadin:vaadin-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q74r-4xw3-ppx9 (GitHub-reviewed advisory GHSA-q74r-4xw3-ppx9 lists affected ranges: Maven com.vaadin:vaadin-bom >=7.4.0 =8.0.0 =7.4.0 =8.0.0 <8.8.5) Commands are suggestions: review each one before running it.
Loading voting…