Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13
CVE-2019-25027GHSA-rp4x-wxqv-cf9m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:flow-server 1.4.3, 1.0.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.vaadin:flow-server
- Affected
- >= 1.0.0, < 1.0.11>= 1.1.0, < 1.4.3
- Fixed in
- 1.0.11, 1.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rp4x-wxqv-cf9m lists affected ranges: Maven com.vaadin:flow-server >=1.0.0 =1.1.0 <1.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-25027: 0.67% estimated exploitation activity in the next 30 days; percentile 51.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Missing output sanitization in default RouteNotFoundError view in com.vaadin:flow-server versions 1.0.0 through 1.0.10 (Vaadin 10.0.0 through 10.0.13), and 1.1.0 through 1.4.2 (Vaadin 11.0.0 through 13.0.5) allows attacker to execute malicious JavaScript via crafted URL. - https://vaadin.com/security/cve-2019-25027
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rp4x-wxqv-cf9m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-25027 Advisory: Reflected cross-site scripting in default RouteNotFoundError view in Vaadin 10 and 11-13 IDs: CVE-2019-25027, GHSA-rp4x-wxqv-cf9m Record: https://patchnext.com/advisories/cve-2019-25027 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.vaadin:flow-server 1.4.3, 1.0.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.vaadin:flow-server: affected >= 1.0.0, < 1.0.11; >= 1.1.0, < 1.4.3; fixed in 1.0.11, 1.4.3 ## Suggested inspection (read-only) - Maven com.vaadin:flow-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.vaadin:flow-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rp4x-wxqv-cf9m (GitHub-reviewed advisory GHSA-rp4x-wxqv-cf9m lists affected ranges: Maven com.vaadin:flow-server >=1.0.0 =1.1.0 <1.4.3) Commands are suggestions: review each one before running it.
Loading voting…