Skip to content

← Actionable
High, CVSS 7.5

Out of bounds write in serde_cbor

CVE-2019-25001GHSA-xr7r-88qv-q7hm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (serde_cbor 0.10.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io serde_cbor

    Affected
    < 0.10.2
    Fixed in
    0.10.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-25001: 1.41% estimated exploitation activity in the next 30 days; percentile 72.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of this crate did not properly check if semantic tags were nested excessively during deserialization. This allows an attacker to craft small (< 1 kB) CBOR documents that cause a stack overflow. The flaw was corrected by limiting the allowed number of nested tags.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xr7r-88qv-q7hm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-25001

Advisory: Out of bounds write in serde_cbor
IDs: CVE-2019-25001, GHSA-xr7r-88qv-q7hm
Record: https://patchnext.com/advisories/cve-2019-25001 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: serde_cbor 0.10.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io serde_cbor: affected < 0.10.2; fixed in 0.10.2

## Suggested inspection (read-only)
- crates.io serde_cbor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on serde_cbor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xr7r-88qv-q7hm (GitHub-reviewed advisory GHSA-xr7r-88qv-q7hm lists affected ranges: crates.io serde_cbor >=0 <0.10.2)

Commands are suggestions: review each one before running it.

Loading voting…