Skip to content

← Actionable
High, CVSS 8.1amended

Improper Access Control in MySQL Connector Python

CVE-2019-2435GHSA-v5rq-w2xm-7g5f

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2019-2435: 2.53% estimated exploitation activity in the next 30 days; percentile 84.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Python). Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Connectors accessible data as well as unauthorized access to critical data or complete access to all MySQL Connectors accessible data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v5rq-w2xm-7g5f

  2. Revision 1 · created ·

    Published from osv record GHSA-v5rq-w2xm-7g5f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-2435

Advisory: Improper Access Control in MySQL Connector Python
IDs: CVE-2019-2435, GHSA-v5rq-w2xm-7g5f
Record: https://patchnext.com/advisories/cve-2019-2435 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: mysql-connector-python 8.0.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mysql-connector-python: affected >= 8.0.0, <= 8.0.13; >= 2.1.0, <= 2.1.8; fixed in 8.0.19

## Suggested inspection (read-only)
- `python -m pip show mysql-connector-python`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mysql-connector-python.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v5rq-w2xm-7g5f (OSV record GHSA-v5rq-w2xm-7g5f lists affected ranges: PyPI mysql-connector-python >=8.0.0 =2.1.0 <=2.1.8)
- Verified: https://github.com/advisories/GHSA-v5rq-w2xm-7g5f (GitHub-reviewed advisory GHSA-v5rq-w2xm-7g5f lists affected ranges: PyPI mysql-connector-python >=8.0.0 =2.1.0 <=2.1.8)

Commands are suggestions: review each one before running it.

Loading voting…