Improper Authentication in InfluxDB
CVE-2019-20933GHSA-2rmp-fw5r-j5qv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/influxdata/influxdb 1.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/influxdata/influxdb
- Affected
- < 1.7.6
- Fixed in
- 1.7.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2rmp-fw5r-j5qv lists affected ranges: Go github.com/influxdata/influxdb >=0 <1.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-20933: 30.92% estimated exploitation activity in the next 30 days; percentile 98.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
InfluxDB before 1.7.6 has an authentication bypass vulnerability in the authenticate function in services/httpd/handler.go because a JWT token may have an empty SharedSecret (aka shared secret).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2rmp-fw5r-j5qv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-20933 Advisory: Improper Authentication in InfluxDB IDs: CVE-2019-20933, GHSA-2rmp-fw5r-j5qv Record: https://patchnext.com/advisories/cve-2019-20933 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/influxdata/influxdb 1.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/influxdata/influxdb: affected < 1.7.6; fixed in 1.7.6 ## Suggested inspection (read-only) - Go github.com/influxdata/influxdb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/influxdata/influxdb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2rmp-fw5r-j5qv (GitHub-reviewed advisory GHSA-2rmp-fw5r-j5qv lists affected ranges: Go github.com/influxdata/influxdb >=0 <1.7.6) Commands are suggestions: review each one before running it.
Loading voting…