Skip to content

← Actionable
High, CVSS 8.7amended

Path Traversal in pip

CVE-2019-20916GHSA-gpvv-69j7-gwj8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pip 19.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pip

    Affected
    < 19.2
    Fixed in
    19.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-20916: 3.00% estimated exploitation activity in the next 30 days; percentile 87.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The pip package before 19.2 for Python allows Directory Traversal when a URL is given in an install command, because a Content-Disposition header can have ../ in a filename, as demonstrated by overwriting the /root/.ssh/authorizedkeys file. This occurs in downloadhttpurl in internal/download.py. A fix was committed 6704f2ace.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gpvv-69j7-gwj8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gpvv-69j7-gwj8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-20916

Advisory: Path Traversal in pip
IDs: CVE-2019-20916, GHSA-gpvv-69j7-gwj8
Record: https://patchnext.com/advisories/cve-2019-20916 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pip 19.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pip: affected < 19.2; fixed in 19.2

## Suggested inspection (read-only)
- `python -m pip show pip`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pip.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gpvv-69j7-gwj8 (OSV record GHSA-gpvv-69j7-gwj8 lists affected ranges: PyPI pip >=0 <19.2 (fixed))
- Verified: https://github.com/advisories/GHSA-gpvv-69j7-gwj8 (GitHub-reviewed advisory GHSA-gpvv-69j7-gwj8 lists affected ranges: PyPI pip >=0 <19.2)

Commands are suggestions: review each one before running it.

Loading voting…