Skip to content

← Actionable
Medium, CVSS 6.1amended

auth0-lock vulnerable to XSS via unsanitized placeholder property

CVE-2019-20174GHSA-w2pf-g6r8-pg22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0-lock 11.21.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-20174: 0.72% estimated exploitation activity in the next 30 days; percentile 54.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Auth0 Lock version 11.20.4 and earlier did not properly sanitize the generated HTML code. Customers using the additionalSignUpFields customization option to add a checkbox to the sign-up dialog that are passing a placeholder property obtained from an untrusted source (e.g. a query parameter) could allow cross-site scripting (XSS) on their signup pages. Am I affected? You are affected by this vulnerability if all of the following conditions apply: - You are using Auth0 Lock version 11.20.4 or earlier. - You pass additionalSignUpFields as options when initializing Lock which includes a field of type checkbox whose placeholder value is obtained from an untrusted source. An example of a vulnerable snippet is the following where the placeholder value is partially user-controlled by the name query parameter: How to fix that? Developers using Auth0’s signin solution Lock need to upgrade to version 11.21.0 or later. Version 11.21.0 introduces two changes: 1. The existing placeholder…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w2pf-g6r8-pg22

  2. Revision 1 · created ·

    Published from osv record GHSA-w2pf-g6r8-pg22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-20174

Advisory: auth0-lock vulnerable to XSS via unsanitized placeholder property
IDs: CVE-2019-20174, GHSA-w2pf-g6r8-pg22
Record: https://patchnext.com/advisories/cve-2019-20174 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0-lock 11.21.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0-lock: affected < 11.21.0; fixed in 11.21.0

## Suggested inspection (read-only)
- `npm ls auth0-lock --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0-lock.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w2pf-g6r8-pg22 (OSV record GHSA-w2pf-g6r8-pg22 lists affected ranges: npm auth0-lock >=0 <11.21.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w2pf-g6r8-pg22 (GitHub-reviewed advisory GHSA-w2pf-g6r8-pg22 lists affected ranges: npm auth0-lock >=0 <11.21.0)

Commands are suggestions: review each one before running it.

Loading voting…