Prototype Pollution in handlebars
CVE-2019-19919GHSA-w457-6q6x-cgp9
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm handlebars
- Affected
- >= 4.0.0, < 4.3.0< 3.0.8
- Fixed in
- 3.0.8, 4.3.0
RubyGems bootstrap-wysihtml5-rails
- Affected
- >= 0.3.3.5, <= 0.3.3.8
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w457-6q6x-cgp9 lists affected ranges: npm handlebars >=4.0.0 =0 =0.3.3.5 <=0.3.3.8
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w457-6q6x-cgp9 lists affected ranges: npm handlebars >=4.0.0 =0 =0.3.3.5 <=0.3.3.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-19919: 7.07% estimated exploitation activity in the next 30 days; percentile 94.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of handlebars prior to 3.0.8 or 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution. Templates may alter an Objects' proto and defineGetter properties, which may allow an attacker to execute arbitrary code through crafted payloads. Recommendation Upgrade to version 3.0.8, 4.3.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w457-6q6x-cgp9
- Revision 1 · created ·
Published from osv record GHSA-w457-6q6x-cgp9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-19919 Advisory: Prototype Pollution in handlebars IDs: CVE-2019-19919, GHSA-w457-6q6x-cgp9 Record: https://patchnext.com/advisories/cve-2019-19919 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: handlebars 4.3.0, 3.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm handlebars: affected >= 4.0.0, < 4.3.0; < 3.0.8; fixed in 3.0.8, 4.3.0 - RubyGems bootstrap-wysihtml5-rails: affected >= 0.3.3.5, <= 0.3.3.8 ## Suggested inspection (read-only) - `npm ls handlebars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - RubyGems bootstrap-wysihtml5-rails: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on handlebars, bootstrap-wysihtml5-rails. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w457-6q6x-cgp9 (OSV record GHSA-w457-6q6x-cgp9 lists affected ranges: npm handlebars >=4.0.0 =0 =0.3.3.5 <=0.3.3.8) - Verified: https://github.com/advisories/GHSA-w457-6q6x-cgp9 (GitHub-reviewed advisory GHSA-w457-6q6x-cgp9 lists affected ranges: npm handlebars >=4.0.0 =0 =0.3.3.5 <=0.3.3.8) Commands are suggestions: review each one before running it.
Loading voting…