Skip to content

← Actionable
Critical, CVSS 9.8

Remote code execution in verot/class.upload.php

CVE-2019-19576GHSA-r5gm-4p5w-pq2p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (verot/class.upload.php 2.0.4, 1.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-19576: 26.38% estimated exploitation activity in the next 30 days; percentile 98.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

class.upload.php in verot.net class.upload before 1.0.3 and 2.x before 2.0.4, as used in the K2 extension for Joomla! and other products, omits .phar from the set of dangerous file extensions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r5gm-4p5w-pq2p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-19576

Advisory: Remote code execution in verot/class.upload.php
IDs: CVE-2019-19576, GHSA-r5gm-4p5w-pq2p
Record: https://patchnext.com/advisories/cve-2019-19576 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: verot/class.upload.php 2.0.4, 1.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist verot/class.upload.php: affected < 1.0.3; >= 2.0.0, < 2.0.4; fixed in 2.0.4, 1.0.3

## Suggested inspection (read-only)
- Packagist verot/class.upload.php: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on verot/class.upload.php.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5gm-4p5w-pq2p (GitHub-reviewed advisory GHSA-r5gm-4p5w-pq2p lists affected ranges: Packagist verot/class.upload.php >=0 =2.0.0 <2.0.4)

Commands are suggestions: review each one before running it.

Loading voting…