SilverStripe Web Cache Poisoning through HTTPRequestBuilder
CVE-2019-19326GHSA-q9ff-3q93-fm8m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 4.5.4, 4.4.7, 3.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/framework
- Affected
- >= 4.0.0, < 4.4.7>= 4.5.0, < 4.5.4>= 3.0.0, < 3.7.5
- Fixed in
- 4.4.7, 4.5.4, 3.7.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q9ff-3q93-fm8m lists affected ranges: Packagist silverstripe/framework >=4.0.0 =4.5.0 =3.0.0 <3.7.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2019-19326: 0.76% estimated exploitation activity in the next 30 days; percentile 55.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SilverStripe through 4.4.4 allows Web Cache Poisoning through HTTPRequestBuilder.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q9ff-3q93-fm8m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-19326 Advisory: SilverStripe Web Cache Poisoning through HTTPRequestBuilder IDs: CVE-2019-19326, GHSA-q9ff-3q93-fm8m Record: https://patchnext.com/advisories/cve-2019-19326 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 4.5.4, 4.4.7, 3.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/framework: affected >= 4.0.0, < 4.4.7; >= 4.5.0, < 4.5.4; >= 3.0.0, < 3.7.5; fixed in 4.4.7, 4.5.4, 3.7.5 ## Suggested inspection (read-only) - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q9ff-3q93-fm8m (GitHub-reviewed advisory GHSA-q9ff-3q93-fm8m lists affected ranges: Packagist silverstripe/framework >=4.0.0 =4.5.0 =3.0.0 <3.7.5) Commands are suggestions: review each one before running it.
Loading voting…