Skip to content

← Actionable
High, CVSS 7.5amended

typed-ast Out-of-bounds Read

CVE-2019-19274GHSA-m3jw-62m7-jjcm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typed-ast 1.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI typed-ast

    Affected
    >= 1.3.0, < 1.3.2
    Fixed in
    1.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2019-19274: 3.28% estimated exploitation activity in the next 30 days; percentile 88.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

typedast 1.3.0 and 1.3.1 has a handlekeywordonlyargs out-of-bounds read. An attacker with the ability to cause a Python interpreter to parse Python source (but not necessarily execute it) may be able to crash the interpreter process. This could be a concern, for example, in a web-based service that parses (but does not execute) Python code. (This issue also affected certain Python 3.8.0-alpha prereleases.)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m3jw-62m7-jjcm

  2. Revision 1 · created ·

    Published from osv record GHSA-m3jw-62m7-jjcm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-19274

Advisory: typed-ast Out-of-bounds Read
IDs: CVE-2019-19274, GHSA-m3jw-62m7-jjcm
Record: https://patchnext.com/advisories/cve-2019-19274 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typed-ast 1.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI typed-ast: affected >= 1.3.0, < 1.3.2; fixed in 1.3.2

## Suggested inspection (read-only)
- `python -m pip show typed-ast`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typed-ast.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m3jw-62m7-jjcm (OSV record GHSA-m3jw-62m7-jjcm lists affected ranges: PyPI typed-ast >=1.3.0 <1.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m3jw-62m7-jjcm (GitHub-reviewed advisory GHSA-m3jw-62m7-jjcm lists affected ranges: PyPI typed-ast >=1.3.0 <1.3.2)

Commands are suggestions: review each one before running it.

Loading voting…