Skip to content

← Actionable
High, CVSS 7.1amended

Django allows unintended model editing

CVE-2019-19118GHSA-hvmf-r92r-27hr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (django 2.2.8, 2.1.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI django

    Affected
    >= 2.1, < 2.1.15>= 2.2, < 2.2.8
    Fixed in
    2.2.8, 2.1.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-19118: 1.67% estimated exploitation activity in the next 30 days; percentile 76.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Django 2.1 before 2.1.15 and 2.2 before 2.2.8 allows unintended model editing. A Django model admin displaying inline related models, where the user has view-only permissions to a parent model but edit permissions to the inline model, would be presented with an editing UI, allowing POST requests, for updating the inline model. Directly editing the view-only parent model was not possible, but the parent model's save() method was called, triggering potential side effects, and causing pre and post-save signal handlers to be invoked. (To resolve this, the Django admin is adjusted to require edit permissions on the parent model in order for inline models to be editable.)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hvmf-r92r-27hr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hvmf-r92r-27hr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-19118

Advisory: Django allows unintended model editing
IDs: CVE-2019-19118, GHSA-hvmf-r92r-27hr
Record: https://patchnext.com/advisories/cve-2019-19118 (revision 3, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: django 2.2.8, 2.1.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI django: affected >= 2.1, < 2.1.15; >= 2.2, < 2.2.8; fixed in 2.2.8, 2.1.15

## Suggested inspection (read-only)
- `python -m pip show django`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on django.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hvmf-r92r-27hr (OSV record GHSA-hvmf-r92r-27hr lists affected ranges: PyPI django >=2.1 =2.2 <2.2.8 (fixed))
- Verified: https://github.com/advisories/GHSA-hvmf-r92r-27hr (GitHub-reviewed advisory GHSA-hvmf-r92r-27hr lists affected ranges: PyPI django >=2.1 =2.2 <2.2.8)

Commands are suggestions: review each one before running it.

Loading voting…