Unauthenticated users can exploit an enumeration vulnerability in Harbor (CVE-2019-19030)
CVE-2019-19030GHSA-q9x4-q76f-5h5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/goharbor/harbor 2.0.1, 1.10.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.7.0, < 1.10.3>= 2.0.0, < 2.0.1
- Fixed in
- 2.0.1, 1.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q9x4-q76f-5h5j lists affected ranges: Go github.com/goharbor/harbor >=1.7.0 =2.0.0 <2.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2019-19030: 1.98% estimated exploitation activity in the next 30 days; percentile 80.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Sean Wright from Secureworks has discovered an enumeration vulnerability. An attacker can make use of the Harbor API to make unauthenticated calls to the Harbor instance. Based on the HTTP status code in the response, an attacker is then able to work out which resources exist, and which do not. This would likely be accomplished by either providing a wordlist or enumerating through a sequence an unauthenticated attacker is able to enumerate resources on the system. This provides them with information such as existing projects, repositories, etc. The vulnerability was immediately fixed by the Harbor team. Issue The following API resources where found to be vulnerable to enumeration attacks: /api/chartrepo/{repo}/prov (POST) /api/chartrepo/{repo}/charts (GET, POST) /api/chartrepo/{repo}/charts/{name} (GET, DELETE) /api/chartrepo/{repo}/charts/{name}/{version} (GET, DELETE) /api/labels?name={name}&scope=p (GET) /api/repositories?projectid={id} (GET) /api/repositories/{reponame}/…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q9x4-q76f-5h5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-19030 Advisory: Unauthenticated users can exploit an enumeration vulnerability in Harbor (CVE-2019-19030) IDs: CVE-2019-19030, GHSA-q9x4-q76f-5h5j Record: https://patchnext.com/advisories/cve-2019-19030 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/goharbor/harbor 2.0.1, 1.10.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/goharbor/harbor: affected >= 1.7.0, < 1.10.3; >= 2.0.0, < 2.0.1; fixed in 2.0.1, 1.10.3 ## Suggested inspection (read-only) - Go github.com/goharbor/harbor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/goharbor/harbor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q9x4-q76f-5h5j (GitHub-reviewed advisory GHSA-q9x4-q76f-5h5j lists affected ranges: Go github.com/goharbor/harbor >=1.7.0 =2.0.0 <2.0.1) Commands are suggestions: review each one before running it.
Loading voting…