Privilege Escalation in Cloud Native Computing Foundation Harbor
CVE-2019-19023GHSA-q6cj-6jvq-jwmh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/goharbor/harbor 1.9.3, 1.8.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.7.0, < 1.8.6>= 1.9.0, < 1.9.3
- Fixed in
- 1.8.6, 1.9.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6cj-6jvq-jwmh lists affected ranges: Go github.com/goharbor/harbor >=1.7.0 =1.9.0 <1.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2019-19023: 1.62% estimated exploitation activity in the next 30 days; percentile 76.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cloud Native Computing Foundation Harbor prior to 1.8.6 and 1.9.3 has a Privilege Escalation Vulnerability in the VMware Harbor Container Registry for the Pivotal Platform.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q6cj-6jvq-jwmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-19023 Advisory: Privilege Escalation in Cloud Native Computing Foundation Harbor IDs: CVE-2019-19023, GHSA-q6cj-6jvq-jwmh Record: https://patchnext.com/advisories/cve-2019-19023 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/goharbor/harbor 1.9.3, 1.8.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/goharbor/harbor: affected >= 1.7.0, < 1.8.6; >= 1.9.0, < 1.9.3; fixed in 1.8.6, 1.9.3 ## Suggested inspection (read-only) - Go github.com/goharbor/harbor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/goharbor/harbor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q6cj-6jvq-jwmh (GitHub-reviewed advisory GHSA-q6cj-6jvq-jwmh lists affected ranges: Go github.com/goharbor/harbor >=1.7.0 =1.9.0 <1.9.3) Commands are suggestions: review each one before running it.
Loading voting…