Skip to content

← Actionable
High, CVSS 8.1

Symfony Http-Kernel has non-constant time comparison in UriSigner

CVE-2019-18887GHSA-q8hg-pf8v-cxrv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 4.3.8, 4.2.12, 3.4.35, 2.8.52; symfony/http-kernel 4.3.8, 4.2.12, 3.4.35, 2.8.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.2.0, < 2.8.52>= 3.0.0, < 3.4.35>= 4.0.0, < 4.2.12>= 4.3.0, < 4.3.8
    Fixed in
    3.4.35, 4.2.12, 2.8.52, 4.3.8
  • Packagist symfony/http-kernel

    Affected
    >= 2.2.0, < 2.8.52>= 3.0.0, < 3.4.35>= 4.0.0, < 4.2.12>= 4.3.0, < 4.3.8
    Fixed in
    3.4.35, 4.2.12, 2.8.52, 4.3.8

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-q8hg-pf8v-cxrv lists affected ranges: Packagist symfony/http-kernel >=2.2.0 =3.0.0 =4.0.0 =4.3.0 =2.2.0 =3.0.0 =4.0.0 =4.3.0 <4.3.8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-18887: 1.34% estimated exploitation activity in the next 30 days; percentile 71.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When checking the signature of an URI (an ESI fragment URL for instance), the URISigner did not used a constant time string comparison function, resulting in a potential remote timing attack vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q8hg-pf8v-cxrv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-18887

Advisory: Symfony Http-Kernel has non-constant time comparison in UriSigner
IDs: CVE-2019-18887, GHSA-q8hg-pf8v-cxrv
Record: https://patchnext.com/advisories/cve-2019-18887 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 4.3.8, 4.2.12, 3.4.35, 2.8.52; symfony/http-kernel 4.3.8, 4.2.12, 3.4.35, 2.8.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.2.0, < 2.8.52; >= 3.0.0, < 3.4.35; >= 4.0.0, < 4.2.12; >= 4.3.0, < 4.3.8; fixed in 3.4.35, 4.2.12, 2.8.52, 4.3.8
- Packagist symfony/http-kernel: affected >= 2.2.0, < 2.8.52; >= 3.0.0, < 3.4.35; >= 4.0.0, < 4.2.12; >= 4.3.0, < 4.3.8; fixed in 3.4.35, 4.2.12, 2.8.52, 4.3.8

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/http-kernel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/http-kernel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q8hg-pf8v-cxrv (GitHub-reviewed advisory GHSA-q8hg-pf8v-cxrv lists affected ranges: Packagist symfony/http-kernel >=2.2.0 =3.0.0 =4.0.0 =4.3.0 =2.2.0 =3.0.0 =4.0.0 =4.3.0 <4.3.8)

Commands are suggestions: review each one before running it.

Loading voting…