XSS in enshrined/svg-sanitize due to mishandled script and data values in attributes
CVE-2019-18857GHSA-gf8j-v8x5-h9qp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (enshrined/svg-sanitize 0.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist enshrined/svg-sanitize
- Affected
- < 0.12.0
- Fixed in
- 0.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gf8j-v8x5-h9qp lists affected ranges: Packagist enshrined/svg-sanitize >=0 <0.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2019-18857: 1.04% estimated exploitation activity in the next 30 days; percentile 63.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
enshrined/svg-sanitize before 0.12.0 mishandles script and data values in attributes, as demonstrated by unexpected whitespace such as in the javascript	:alert substring.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gf8j-v8x5-h9qp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-18857 Advisory: XSS in enshrined/svg-sanitize due to mishandled script and data values in attributes IDs: CVE-2019-18857, GHSA-gf8j-v8x5-h9qp Record: https://patchnext.com/advisories/cve-2019-18857 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: enshrined/svg-sanitize 0.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist enshrined/svg-sanitize: affected < 0.12.0; fixed in 0.12.0 ## Suggested inspection (read-only) - Packagist enshrined/svg-sanitize: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on enshrined/svg-sanitize. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gf8j-v8x5-h9qp (GitHub-reviewed advisory GHSA-gf8j-v8x5-h9qp lists affected ranges: Packagist enshrined/svg-sanitize >=0 <0.12.0) Commands are suggestions: review each one before running it.
Loading voting…