Skip to content

← Actionable
High, CVSS 7.5

JSON-jwt Gem lacked element count during splitting of JWE string

CVE-2019-18848GHSA-cff7-6h4q-q5pj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (json-jwt 1.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems json-jwt

    Affected
    < 1.11.0
    Fixed in
    1.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2019-18848: 1.26% estimated exploitation activity in the next 30 days; percentile 69.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The json-jwt gem before 1.11.0 for Ruby lacks an element count during the splitting of a JWE string.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cff7-6h4q-q5pj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-18848

Advisory: JSON-jwt Gem lacked element count during splitting of JWE string
IDs: CVE-2019-18848, GHSA-cff7-6h4q-q5pj
Record: https://patchnext.com/advisories/cve-2019-18848 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: json-jwt 1.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems json-jwt: affected < 1.11.0; fixed in 1.11.0

## Suggested inspection (read-only)
- RubyGems json-jwt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on json-jwt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cff7-6h4q-q5pj (GitHub-reviewed advisory GHSA-cff7-6h4q-q5pj lists affected ranges: RubyGems json-jwt >=0 <1.11.0)

Commands are suggestions: review each one before running it.

Loading voting…