Skip to content

← Actionable
Critical, CVSS 9.8amended

Strapi allows unauthenticated attacker to reset admin password without valid reset token

CVE-2019-18818GHSA-6xc2-mj39-q599

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (strapi 3.0.0-beta.17.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm strapi

    Affected
    <= 3.0.0-beta.17.4
    Fixed in
    3.0.0-beta.17.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-18818: 97.64% estimated exploitation activity in the next 30 days; percentile 99.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of strapi prior to 3.0.0-beta.17.5 are vulnerable to Privilege Escalation. The password reset routes allows an unauthenticated attacker to reset an admin's password without providing a valid password reset token. Recommendation Upgrade to version 3.0.0-beta.17.5 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6xc2-mj39-q599

  2. Revision 1 · created ·

    Published from osv record GHSA-6xc2-mj39-q599

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-18818

Advisory: Strapi allows unauthenticated attacker to reset admin password without valid reset token
IDs: CVE-2019-18818, GHSA-6xc2-mj39-q599
Record: https://patchnext.com/advisories/cve-2019-18818 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: strapi 3.0.0-beta.17.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm strapi: affected <= 3.0.0-beta.17.4; fixed in 3.0.0-beta.17.5

## Suggested inspection (read-only)
- `npm ls strapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on strapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6xc2-mj39-q599 (OSV record GHSA-6xc2-mj39-q599 lists affected ranges: npm strapi >=0 <3.0.0-beta.17.5 (fixed))
- Verified: https://github.com/advisories/GHSA-6xc2-mj39-q599 (GitHub-reviewed advisory GHSA-6xc2-mj39-q599 lists affected ranges: npm strapi >=0 <=3.0.0-beta.17.4)

Commands are suggestions: review each one before running it.

Loading voting…