SQL Injection and Cross-site Scripting in class-validator
CVE-2019-18413GHSA-fj58-h2fr-3pp2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (class-validator 0.14.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm class-validator
- Affected
- < 0.14.0
- Fixed in
- 0.14.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fj58-h2fr-3pp2 lists affected ranges: npm class-validator >=0 <0.14.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fj58-h2fr-3pp2 lists affected ranges: npm class-validator >=0 <0.14.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-18413: 1.99% estimated exploitation activity in the next 30 days; percentile 80.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In TypeStack class-validator, validate() input validation can be bypassed because certain internal attributes can be overwritten via a conflicting name. Even though there is an optional forbidUnknownValues parameter that can be used to reduce the risk of this bypass, this option is not documented and thus most developers configure input validation in the vulnerable default manner. With this vulnerability, attackers can launch SQL Injection or XSS attacks by injecting arbitrary malicious input. The default settings for forbidUnknownValues has been changed to true in 0.14.0. NOTE: a software maintainer agrees with the "is not documented" finding but suggests that much of the responsibility for the risk lies in a different product.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fj58-h2fr-3pp2
- Revision 1 · created ·
Published from osv record GHSA-fj58-h2fr-3pp2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-18413 Advisory: SQL Injection and Cross-site Scripting in class-validator IDs: CVE-2019-18413, GHSA-fj58-h2fr-3pp2 Record: https://patchnext.com/advisories/cve-2019-18413 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: class-validator 0.14.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm class-validator: affected < 0.14.0; fixed in 0.14.0 ## Suggested inspection (read-only) - `npm ls class-validator --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on class-validator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fj58-h2fr-3pp2 (OSV record GHSA-fj58-h2fr-3pp2 lists affected ranges: npm class-validator >=0 <0.14.0 (fixed)) - Verified: https://github.com/advisories/GHSA-fj58-h2fr-3pp2 (GitHub-reviewed advisory GHSA-fj58-h2fr-3pp2 lists affected ranges: npm class-validator >=0 <0.14.0) Commands are suggestions: review each one before running it.
Loading voting…