Skip to content

← Actionable
High, CVSS 7.5

Nokogiri affected by libxslt Use of Uninitialized Resource/Use After Free vulnerability

CVE-2019-18197GHSA-242x-7cm6-4w8j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems nokogiri

    Affected
    < 1.10.5
    Fixed in
    1.10.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-18197: 4.45% estimated exploitation activity in the next 30 days; percentile 91.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In xsltCopyText in transform.c in libxslt 1.1.33, a pointer variable isn't reset under certain circumstances. If the relevant memory area happened to be freed and reused in a certain way, a bounds check could fail and memory outside a buffer could be written to, or uninitialized data could be disclosed. Nokogiri prior to version 1.10.5 contains a vulnerable version of libxslt. Nokogiri version 1.10.5 upgrades the dependency to libxslt 1.1.34, which contains a patch for this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-242x-7cm6-4w8j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-18197

Advisory: Nokogiri affected by libxslt Use of Uninitialized Resource/Use After Free vulnerability
IDs: CVE-2019-18197, GHSA-242x-7cm6-4w8j
Record: https://patchnext.com/advisories/cve-2019-18197 (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems nokogiri: affected < 1.10.5; fixed in 1.10.5

## Suggested inspection (read-only)
- RubyGems nokogiri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nokogiri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-242x-7cm6-4w8j (GitHub-reviewed advisory GHSA-242x-7cm6-4w8j lists affected ranges: RubyGems nokogiri >=0 <1.10.5)

Commands are suggestions: review each one before running it.

Loading voting…