Skip to content

← Actionable
Medium, CVSS 6.1

Unescaped exception messages in error responses in Jetty

CVE-2019-17632GHSA-5h9j-q6j2-253f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-server 9.4.24.v20191120), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.eclipse.jetty:jetty-server

    Affected
    >= 9.4.21.v20190926, <= 9.4.21.v20190926>= 9.4.22.v20191022, <= 9.4.22.v20191022>= 9.4.23.v20191118, <= 9.4.23.v20191118
    Fixed in
    9.4.24.v20191120

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-5h9j-q6j2-253f lists affected ranges: Maven org.eclipse.jetty:jetty-server >=9.4.21.v20190926 =9.4.22.v20191022 =9.4.23.v20191118 <=9.4.23.v20191118

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-17632: 1.91% estimated exploitation activity in the next 30 days; percentile 79.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Eclipse Jetty versions 9.4.21.v20190926, 9.4.22.v20191022, and 9.4.23.v20191118, the generation of default unhandled Error response content (in text/html and text/json Content-Type) does not escape Exception messages in stacktraces included in error output.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5h9j-q6j2-253f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-17632

Advisory: Unescaped exception messages in error responses in Jetty
IDs: CVE-2019-17632, GHSA-5h9j-q6j2-253f
Record: https://patchnext.com/advisories/cve-2019-17632 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-server 9.4.24.v20191120. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty:jetty-server: affected >= 9.4.21.v20190926, <= 9.4.21.v20190926; >= 9.4.22.v20191022, <= 9.4.22.v20191022; >= 9.4.23.v20191118, <= 9.4.23.v20191118; fixed in 9.4.24.v20191120

## Suggested inspection (read-only)
- Maven org.eclipse.jetty:jetty-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty:jetty-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5h9j-q6j2-253f (GitHub-reviewed advisory GHSA-5h9j-q6j2-253f lists affected ranges: Maven org.eclipse.jetty:jetty-server >=9.4.21.v20190926 =9.4.22.v20191022 =9.4.23.v20191118 <=9.4.23.v20191118)

Commands are suggestions: review each one before running it.

Loading voting…