Regular Expression Denial of Service in csv-parse
CVE-2019-17592GHSA-582f-p4pg-xc74
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (csv-parse 4.4.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm csv-parse
- Affected
- < 4.4.6
- Fixed in
- 4.4.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-582f-p4pg-xc74 lists affected ranges: npm csv-parse >=0 <4.4.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-582f-p4pg-xc74 lists affected ranges: npm csv-parse >=0 <4.4.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2019-17592: 2.28% estimated exploitation activity in the next 30 days; percentile 83.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of csv-parse prior to 4.4.6 are vulnerable to Regular Expression Denial of Service. The isInt() function contains a malformed regular expression that processes large specially-crafted input very slowly, leading to a Denial of Service. This is triggered when using the cast option. Recommendation Upgrade to version 4.4.6 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-582f-p4pg-xc74
- Revision 1 · created ·
Published from osv record GHSA-582f-p4pg-xc74
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-17592 Advisory: Regular Expression Denial of Service in csv-parse IDs: CVE-2019-17592, GHSA-582f-p4pg-xc74 Record: https://patchnext.com/advisories/cve-2019-17592 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: csv-parse 4.4.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm csv-parse: affected < 4.4.6; fixed in 4.4.6 ## Suggested inspection (read-only) - `npm ls csv-parse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on csv-parse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-582f-p4pg-xc74 (OSV record GHSA-582f-p4pg-xc74 lists affected ranges: npm csv-parse >=0 <4.4.6 (fixed)) - Verified: https://github.com/advisories/GHSA-582f-p4pg-xc74 (GitHub-reviewed advisory GHSA-582f-p4pg-xc74 lists affected ranges: npm csv-parse >=0 <4.4.6) Commands are suggestions: review each one before running it.
Loading voting…