Skip to content

← Actionable
Medium, CVSS 4.8

Potential HTTP request smuggling in Apache Tomcat

CVE-2019-17569GHSA-767j-jfh2-jvrc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat.embed:tomcat-embed-core 9.0.31, 8.5.51, 7.0.100; org.apache.tomcat:tomcat 9.0.31, 8.5.51, 7.0.100), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-767j-jfh2-jvrc lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=7.0.98 =8.5.48 =9.0.28 =7.0.98 =8.5.48 =9.0.28 <9.0.31

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2019-17569: 8.87% estimated exploitation activity in the next 30 days; percentile 95.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The refactoring present in Apache Tomcat versions 9.0.28 to 9.0.30, 8.5.48 to 8.5.50 and 7.0.98 to 7.0.99 introduced a regression. The result of the regression was that invalid Transfer-Encoding headers were incorrectly processed leading to a possibility of HTTP Request Smuggling if Tomcat was located behind a reverse proxy that incorrectly handled the invalid Transfer-Encoding header in a particular manner. Such a reverse proxy is considered unlikely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-767j-jfh2-jvrc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-17569

Advisory: Potential HTTP request smuggling in Apache Tomcat
IDs: CVE-2019-17569, GHSA-767j-jfh2-jvrc
Record: https://patchnext.com/advisories/cve-2019-17569 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat.embed:tomcat-embed-core 9.0.31, 8.5.51, 7.0.100; org.apache.tomcat:tomcat 9.0.31, 8.5.51, 7.0.100. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 7.0.98, < 7.0.100; >= 8.5.48, < 8.5.51; >= 9.0.28, < 9.0.31; fixed in 9.0.31, 8.5.51, 7.0.100
- Maven org.apache.tomcat:tomcat: affected >= 7.0.98, < 7.0.100; >= 8.5.48, < 8.5.51; >= 9.0.28, < 9.0.31; fixed in 9.0.31, 8.5.51, 7.0.100

## Suggested inspection (read-only)
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-767j-jfh2-jvrc (GitHub-reviewed advisory GHSA-767j-jfh2-jvrc lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=7.0.98 =8.5.48 =9.0.28 =7.0.98 =8.5.48 =9.0.28 <9.0.31)

Commands are suggestions: review each one before running it.

Loading voting…