Deserialization of Untrusted Data in Apache Dubbo
CVE-2019-17564GHSA-69wp-3pm3-hxgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.dubbo:dubbo-rpc-http-invoker 2.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.dubbo:dubbo-rpc-http-invoker
- Affected
- >= 2.5.0, < 2.7.5
- Fixed in
- 2.7.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-69wp-3pm3-hxgg lists affected ranges: Maven org.apache.dubbo:dubbo-rpc-http-invoker >=2.5.0 <2.7.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2019-17564: 36.51% estimated exploitation activity in the next 30 days; percentile 98.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Unsafe deserialization occurs within a Dubbo application which has HTTP remoting enabled. An attacker may submit a POST request with a Java object in it to completely compromise a Provider instance of Apache Dubbo, if this instance enables HTTP. This issue affected Apache Dubbo 2.7.0 to 2.7.4, 2.6.0 to 2.6.7, and all 2.5.x versions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-69wp-3pm3-hxgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-17564 Advisory: Deserialization of Untrusted Data in Apache Dubbo IDs: CVE-2019-17564, GHSA-69wp-3pm3-hxgg Record: https://patchnext.com/advisories/cve-2019-17564 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.dubbo:dubbo-rpc-http-invoker 2.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.dubbo:dubbo-rpc-http-invoker: affected >= 2.5.0, < 2.7.5; fixed in 2.7.5 ## Suggested inspection (read-only) - Maven org.apache.dubbo:dubbo-rpc-http-invoker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.dubbo:dubbo-rpc-http-invoker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-69wp-3pm3-hxgg (GitHub-reviewed advisory GHSA-69wp-3pm3-hxgg lists affected ranges: Maven org.apache.dubbo:dubbo-rpc-http-invoker >=2.5.0 <2.7.5) Commands are suggestions: review each one before running it.
Loading voting…