Improper Input Validation in Apache Solr
CVE-2019-17558GHSA-ww97-9w65-2crx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 8.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.solr:solr-core
- Affected
- >= 5.0.0, <= 5.5.5>= 6.0.0, <= 6.6.6>= 7.0.0, <= 7.7.2>= 8.0.0, <= 8.3.1
- Fixed in
- 8.4.0
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2019-17558 to the Known Exploited Vulnerabilities catalog on 2021-11-03.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2021-11-03).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ww97-9w65-2crx lists affected ranges: Maven org.apache.solr:solr-core >=5.0.0 =6.0.0 =7.0.0 =8.0.0 <=8.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H
- EPSS
- CVE-2019-17558: 98.57% estimated exploitation activity in the next 30 days; percentile 99.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code Execution through the VelocityResponseWriter. A Velocity template can be provided through Velocity templates in a configset velocity/ directory or as a parameter. A user defined configset could contain renderable, potentially malicious, templates. Parameter provided templates are disabled by default, but can be enabled by setting params.resource.loader.enabled by defining a response writer with that setting set to true. Defining a response writer requires configuration API access. Solr 8.4 removed the params resource loader entirely, and only enables the configset-provided template rendering when the configset is trusted (has been uploaded by an authenticated user).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ww97-9w65-2crx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-17558 Advisory: Improper Input Validation in Apache Solr IDs: CVE-2019-17558, GHSA-ww97-9w65-2crx Record: https://patchnext.com/advisories/cve-2019-17558 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 8.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.solr:solr-core: affected >= 5.0.0, <= 5.5.5; >= 6.0.0, <= 6.6.6; >= 7.0.0, <= 7.7.2; >= 8.0.0, <= 8.3.1; fixed in 8.4.0 ## Suggested inspection (read-only) - Maven org.apache.solr:solr-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.solr:solr-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2019-17558 to the Known Exploited Vulnerabilities catalog on 2021-11-03.) - Verified: https://github.com/advisories/GHSA-ww97-9w65-2crx (GitHub-reviewed advisory GHSA-ww97-9w65-2crx lists affected ranges: Maven org.apache.solr:solr-core >=5.0.0 =6.0.0 =7.0.0 =8.0.0 <=8.3.1) Commands are suggestions: review each one before running it.
Loading voting…